Home Ask Login Register

Developers Planet

Your answer is one click away!

Tobias Fünke February 2016

How do I get rid of this popup in VSCode?

This little pop up comes up when I start typing new properties in objects, and seemingly all the time. It prevents me moving up/down lines because the up/down arrows scroll the contents of the box. I'm sorry to say it feels like the VSCode version of Clippy from MS Word!

enter image description here

I've tried the following user settings to no avail

// Place your settings in this file to overwrite the default settings
{
  "editor.referenceInfos": false,
  "editor.suggestOnTriggerCharacters": false,
  "editor.autoClosingBrackets": false,
  "editor.quickSuggestions": false
}

Answers


Tobiah Zarlez February 2016

That is the intellisense/refactoring support. Beyond the user settings you mentioned, it's part of the language support.

You could:

  • Switch to a different "Language" setting
  • Make a custom language support, that adds the intellisense features you like without the full support, then modify your vscode installation to remove the original support.
  • Press the ESC key before up/down to close the popup

Post Status

Asked in February 2016
Viewed 1,332 times
Voted 9
Answered 1 times

Search




Leave an answer


Quote of the day: live life