Keval February 2016

Why does JVM error occur?

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007ff17a60c678, pid=4219, tid=140673779791616
#
# JRE version: Java(TM) SE Runtime Environment (8.0-b124) (build 1.8.0-ea-b124)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.0-b66 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V  [libjvm.so+0x665678]  jni_invoke_nonstatic(JNIEnv_*, JavaValue*, _jobject*, JNICallType, _jmethodID*, JNI_ArgumentPusher*, Thread*)+0x38
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /media/data/K's World/javaFX/ChatApp/hs_err_pid4219.log
Compiled method (c1)   16675  988       3       java.util.concurrent.atomic.AtomicBoolean::set (14 bytes)
 total in heap  [0x00007ff16535ef50,0x00007ff16535f2a0] = 848
 relocation     [0x00007ff16535f070,0x00007ff16535f0a0] = 48
 main code      [0x00007ff16535f0a0,0x00007ff16535f1c0] = 288
 stub code      [0x00007ff16535f1c0,0x00007ff16535f250] = 144
 metadata       [0x00007ff16535f250,0x00007ff16535f258] = 8
 scopes data    [0x00007ff16535f258,0x00007ff16535f268] = 16
 scopes pcs     [0x00007ff16535f268,0x00007ff16535f298] = 48
 dependencies   [0x00007ff16535f298,0x00007ff16535f2a0] = 8
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
#

I am writing chat App in javaFx..and I am using eclipse IDE.. My Application is running well but I don't know why suddenly application has been stopped.

Answers


paulsm4 February 2016

It sounds like you're running JavaFX with Java 8 on Linux, and you've run into this bug:

https://bugs.openjdk.java.net/browse/JDK-8141687

App crashes while starting Main.class in JavaFx

ava version "1.8.0_60" Java(TM) SE Runtime Environment (build 1.8.0_60-b27) Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

ADDITIONAL OS VERSION INFORMATION : Mint17.2 Cinnamon 64Bit

SUGGESTION: Try a different version of Java/JavaFX.

  1. Run sudo update-alternatives --config java to see what alternatives are already present on your system. I would downgrade to Java 1.7 if possible.

  2. If there are no suitable candidates, use apt-get install openjdk-7-jdk:

Post Status

Asked in February 2016
Viewed 2,105 times
Voted 14
Answered 1 times

Search




Leave an answer