Home Ask Login Register

Developers Planet

Your answer is one click away!

WaaX February 2016

GNU Radio, debian compilation error

have problem when am trying to compile gnuradio 3.6.5 on the latest debian version (8.3).

My gcc version output :

Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.9/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 4.9.2-10' --with-bugurl=file:///usr/share/doc/gcc-4.9/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.9 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.9 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.9-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.9-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.9-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --with-arch-32=i586 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.9.2 (Debian 4.9.2-10) 

The make error :

[  1%] Built target volk
[  1%] Built target test_all
[  1%] Built target volk_profile
[  1%] Built target doxygen_target
[  2%] Built target gruel
[  2%] Built target test_gruel
[  2%] Built target pmt_generated
[  2%] Built target _pmt_swig_doc_tag
[  2%] Built target pmt_swig_swig_doc
[  2%] Built target _pmt_swig_swig_tag
[  2%] Built target _pmt_swig
[  3%] Built target pygen_gruel_src_swig_8de72
[  3%] Built target pygen_gruel_src_python_3        

Answers


Marcus Müller February 2016

This typically is a problem with a different version of GNU Radio that's already installed on your system. So make sure to apt-get remove gnuradio beforehand.


Marcus Müller February 2016

As you wrote:

Solved by using GNURadio 3.7.5 + gr3.7 branch of osmotetra.

You shouldn't be using GNU Radio pre-3.7 if you don't have to; since osmo-tetra has a gr3.7 branch, which works with latest GNU Radio, go for that.

Post Status

Asked in February 2016
Viewed 3,830 times
Voted 11
Answered 2 times

Search




Leave an answer


Quote of the day: live life