Home Ask Login Register

Developers Planet

Your answer is one click away!

Simon February 2016

Windows 10 mobile - Unable to deploy project to device

We've got a Windows Phone Silverlight 8.1 project which we need to debug on a Windows 10 mobile device. When we attempt to deploy to the device we get the following errors:

'Install failed. Please contact your software vendor'

and then a popup message:

'A specified communication resource is already in use by another application'

We've tried:

  • Multiple Windows 10 mobile devices (one bought with Windows 10 installed, and one we've updated from 8.1)
  • Deploying from two different development machines (same error produced)
  • Deleting any previous versions of the app installed on the device
  • Updating visual studio to the latest version with the latest Windows 10 sdk and emulators
  • Both the development machine and the Windows 10 mobile devices have 'Developer mode' enabled in the 'For developers' settings panel

The app deploys and runs fine on Windows Phone 8.1, and to the emulators running Windows Phone 8.1 & 10.

We only get the problem deploying to a physical device.

edit: Actually, after installing more emulators, the app in fact does not run on some Windows 10 mobile emulators.

The app runs fine on: Emulator 720p 5 inch 1GB

but does not run on: Mobile Emulator 10.0.10586.0 QHD 5.2 inch 3GB


Ceyhun Keklik February 2016

You can try again after you delete these references in the device manager, after that, you can unplug device and plug again for install drivers again.

For open device manager; run this command "mmc devmgmt.msc"

Windows Phone Hardware in the Device Manager

Simon February 2016

If anyone else is having an issue with deploying to Windows 10 mobile, check your Version number in the WMAppManifest.

Our project version numbers are set by our build server, which means we just had in the project itself.

This is fine on Windows Phone 8, but on Windows 10 Mobile... nope, won't deploy!

Post Status

Asked in February 2016
Viewed 1,062 times
Voted 4
Answered 2 times


Leave an answer

Quote of the day: live life