KDeogharkar February 2016

Always have to set Target Membership for .a File

I am using Flyer and Crittercism in my project . both have libAppsFlyerLib.a and libCrittercism_v4_3_4.a respectively.

enter image description here

Now whenever I open my project and run it I always got this error first time.

ld: warning: directory not found for option '-LApp/Model/Utility/CrittercismSDK'
ld: warning: directory not found for option '-LApp/Model/CrittercismSDK'
ld: warning: directory not found for option '-LApp'
ld: warning: directory not found for option '-LApp/Model/Flyer'
ld: warning: directory not found for option '-FApp/Model/Fabric'
ld: library not found for -lAppsFlyerLib
clang: error: linker command failed with exit code 1 (use -v to see invocation)

To resolve this I have to uncheck and again check Target Membership to Project for both libAppsFlyerLib.a and libCrittercism_v4_3_4.a manually.After that project is running fine.

enter image description here

Why I have to always set membership for .a file manually first time? Am I missing something here?

Answers


KDeogharkar February 2016

Because of @trojanfoe's suggestion I get right direction to solve this issue and found that it is happening because it has no library search path in build->setting . So I set path to both .a in library search path file and it works.

Post Status

Asked in February 2016
Viewed 2,795 times
Voted 7
Answered 1 times

Search




Leave an answer