Kartik Jhakal February 2016

Installing NPM on Ubuntu 14.0 giving python 2.7 dependency issue

I am installing npm on the ubuntu 14.0. It is already having installed python 2.7.11. It is showing the following error.

Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     apt-xapian-index : Depends: python:any (>= 2.7.1-0ubuntu2)
     duplicity : Depends: python:any (>= 2.7.1-0ubuntu2)
     gconf2 : Depends: python:any
     hplip-data : Depends: python:any (>= 2.7.1-0ubuntu2)
     ibus : Depends: python:any (>= 2.7.1-0ubuntu2)
     ibus-pinyin : Depends: python:any (>= 2.7.1-0ubuntu2)
     ibus-table : Depends: python:any (>= 2.7.1-0ubuntu2)
     landscape-client-ui-install : Depends: python:any
     npm : Depends: nodejs but it is not going to be installed
           Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
           Depends: node-ansi but it is not going to be installed
           Depends: node-archy but it is not going to be installed
           Depends: node-block-stream but it is not going to be installed
           Depends: node-fstream (>= 0.1.22) but it is not going to be installed
           Depends: node-fstream-ignore but it is not going to be installed
           Depends: node-github-url-from-git but it is not going to be installed
           Depends: node-glob (>= 3.1.21) but it is not going to be installed
           Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
           Depends: node-inherits but it is not going to be installed
           Depends: node-ini (>= 1.1.0) but it is not going to be installed
           Depends: node-lockfile but it is not going to be installed
           Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
           Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
           Depends: node-mkdirp (>= 0.3.3) but it is not going t        

Answers


suzumakes February 2016

You might want to run 'apt-get -f install' to correct these:

Try 'apt-get -f install' with no packages

You try what it told you to do?

Post Status

Asked in February 2016
Viewed 2,354 times
Voted 13
Answered 1 times

Search




Leave an answer