daylight February 2016

AVD Manager on Android Studio 1.5.1 and install to a custom location emulator won't run

I installed Android Studio (1.5.1 -- see image for build details). enter image description here

While installing I chose the custom option so I could install a specific path. I knew that my %SystemDrive% was pointed at a network location and I wanted to install to my local disk.

So, this means that by default, the application would've installed to : \networkpath\users\myUserName\Android\SDK

However, since I chose the custom installation I chose a local path: c:\users\myUsername\Android\SDK

Project Creation and Build Work Fine

Everything seemed to install fine and I was able to create a new project and build it with no problems.

However, when I attempted to run the built and then basically failed silently. The emulator never appeared and no error occurred. Android Monitor just shows a message stating that No Connected Device detected. AVD Manager

Luckily I knew a bit about checking to see what happened with the emulator and I opened up AVD Manager. The listed device displayed an error. I right-clicked the device and chose "View Details". That's when the AVD manager showed that it is attempting to read from the network path, even though I changed this in the custom installation. \networkPath\Users\myUserName\Windows.android\avd\Nexus4.avd and \networkPath\Users\myUserName\Windows.android\avd\Nexus4.ini

Registry Edit

I closed Android Studio. Then I opened regedit and edited the values at: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList which originally looked like the following: registry values

And changed them so they all point directly to the c:\ drive (instead of %systemdrive%)

Environment Variable :

Answers


daylight February 2016

EDIT 2 With Final Solution

Thanks to an alert and astute SO post-er (code-apprentice) I was able to get to a solution.

Here's what I had to do.

  1. create idea.properties file and place it at the \networkLocation\myUserName\.Android 1.5\
  2. place the two lines in it which point to my local disk

idea.config.path=C:/Users/myUserName/.AndroidStudio1.5/config/ idea.system.path=C:/Users/myUserName/.AndroidStudio1.5/system/

Then I started Android Studio again and I attempt to install a system image which included the Google APIs. It worked and it was added to the list: system image

However, it still did not show the other API LEVELS which I had installed before (15, 16, etc).

Deleted Them From Disk

I noticed that they had been located in a local folder at : %userprofile%\Android\SDK\add-ons for whatever reason. I deleted all of the folders under that path and the original APIs with Google choices appeared in my list again. See highlighted item in image.

google api LEVEL 15

SOLUTION Now when I install them they show up in the list and I can create new AVDs based upon them. Everything works.

EDIT I used a tool I wrote to watch where Android Studio wrote to disk and I found a path that reveals the problem:

still accesses network path

Even though I've made extensive changes to insure the installation would install completely on my local disk,


Code-Apprentice February 2016

You should look in the idea.properties file in your project (Android Studio path to different directories). It sounds like this is set to override the system's settings.

Post Status

Asked in February 2016
Viewed 1,829 times
Voted 10
Answered 2 times

Search




Leave an answer