for new versions of rxvt and surf I need Perl v5.20+.
That's not true.
rxvt 2.7.10 uses a Perl script will work even with 15 year-old 5.6.
surf 1.0.6 doesn't use Perl at all (assuming you mean this project).
Were you to try to install these from source, it wouldn't matter at all what Perl you had available.
Instead, you appear to be trying to install packages built for a system other than yours. To install the rxvt and surf packages you have, you need to have version 5.20 of the distributor's perl package. No matter how many version of perl you install, you'll never satisfy that requirement.
You can't install those packages. You'll need packages appropriate for your system, or you'll need to install the libraries from source.
Asked in February 2016Viewed 1,659 timesVoted 8Answered 1 times