Sonique February 2016

How to use brewperl for installing applications on Ubuntu

I am use Ubuntu 14.04 LTS with Perl 5 (v5.18.2), but for new versions of rxvt and surf I need Perl v5.20+.

As solution I found perlbrew and install Perl v5.20, found .deb with rxvt, but anyway cannot install, because it use system Perl.

My question is how to install applications on Linux with Perl dependency and do not break internal compatibility of Linux Core?

Answers


ikegami February 2016

for new versions of rxvt and surf I need Perl v5.20+.

That's not true.

rxvt 2.7.10 uses a Perl script will work even with 15 year-old 5.6.

surf 1.0.6 doesn't use Perl at all (assuming you mean this project).

Were you to try to install these from source, it wouldn't matter at all what Perl you had available.

Instead, you appear to be trying to install packages built for a system other than yours. To install the rxvt and surf packages you have, you need to have version 5.20 of the distributor's perl package. No matter how many version of perl you install, you'll never satisfy that requirement.

You can't install those packages. You'll need packages appropriate for your system, or you'll need to install the libraries from source.

Post Status

Asked in February 2016
Viewed 1,659 times
Voted 8
Answered 1 times

Search




Leave an answer