user998507 February 2016

I've moved to an SSL and now my popup menu doesn't work

I've moved to an SSL and now my popup menu on the nav doesn't work. It did work before hand. I can't see why it's not working. I didn't do anything to the CSS or javascript code.

$(document).ready(function(){
  // Mobile menu toggle
  $('.fa-reorder').click(function(){
    $('body>nav ul').slideToggle();
  });
  //Checkboxes customization
  $(':checkbox').click(function(e){
    if ($(this).is(':checked')) $(this).addClass('checked');
    else $(this).removeClass('checked');
  });
  //landing page popups
  $('#signup').click(function(){
    $('#signup-popup, #cover').show();
    $('#cover, .fa-times').click(function(){
      $('#cover, #signup-popup').hide();
    });
  });
  $('#login').click(function(){
    $('#login-popup, #cover').show();
    $('#cover, .fa-times').click(function(){
      $('#cover, #login-popup').hide();
    });
  });
});
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
<nav>
  <i class="fa fa-reorder"></i>
  <ul>
    <li><a href="https://www.serviceposts.com">HOME</a></li>
    <li><a href="https://www.serviceposts.com/site/postings">POSTS</a></li>
    <li><a href="https://www.serviceposts.com/site/about/hspw.php">HOW IT     WORKS</a></li>
    <li><a href="https://www.serviceposts.com/site/about">ABOUT</a></li>
    <li><a href="https://www.serviceposts.com/site/about/emailcsb.php">CONTACT</a></li>
  </ul>
  <div class="buttons">
    <input type="button" class="button green" value="SIGN UP" id="signup">
    <input type="button" class="button" value="LOGIN" id        

Answers


imRcH February 2016

The best practice is adding a redirect from http to https (web server will redirect all clients requests to https, if we forget change protocol in your app configuration):

Apache exemple:

<VirtualHost *:80>
    ServerName www.example.com
    Redirect "/" "https://www.example.com/"
</VirtualHost >

<VirtualHost *:443>
    ServerName www.example.com
    # ... SSL configuration goes here
</VirtualHost >

nginx exemple:

server {
  listen *:80;
  server_name example.com;
  proxy_set_header Host example.com;
  location / {
    rewrite ^(.*)$ https://example.com$1 permanent;
  }
}
server {
  listen *:443 ssl;
  server_name example.com;
  proxy_set_header Host example.com;
  location / {
    proxy_pass http://127.0.0.1:8080;
  }
}


Houssam Chehadi February 2016

This is mostly a cashing issue, or URL-rewrite issue. If you are using a framework such as WordPress then this is a URL issue, since the links are stored in database, all you need to do is change main URL to be with https.

If not, then you got a caching issue, just purge cache and refresh your page.

Please note that if you purchase an CDN with your SSL that you disable the auto-minify option.0

Post Status

Asked in February 2016
Viewed 2,049 times
Voted 4
Answered 2 times

Search




Leave an answer