Randy Mad-Dog February 2016

Fedora 23 unmanaged nework interfaces refuse to be up at boot

Is there a bug with Fedora 23 and unmanaged network devices? I am trying to configure a server and as soon as I place "NM_CONTROLLED=no" in my ifcfg-enp4s0f0 and ifcfg-enp4s0f1 lines, the devices are not active after bootup. If I issue a "service network restart" it will then make them active. "nmcli dev status" shows that they are unmanaged so I know the line is doing that.
/etc/sysconfig/network-scripts/ifcfg-enp4s0f1 reads:

NM_CONTROLLED=no
HWADDR=00:12:34:56:78:90 
TYPE=Ethernet
BOOTPROTO=none
IPADDR=10.0.0.1
NETMASK=255.255.0.0
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
NAME=enp4s0f1
UUID=blablablablabalbla
ONBOOT=yes

I have been using Fedora for many years and really don't think I am missing anything. I even went as far as to place "NETWORKING=yes" in /etc/sysconfig/network as is necessary in the older versions. Nothing seems to work where the interfaces are up once it's finished booting. I need to issue a service network restart command (which I know redirects to systemctl commands but I have not gotten used to it's syntax yet)

Is anyone else seeing this problem? Am I missing something? I really don't think so, but am all ears if anybody has any suggestions. All I have done on this installation since installing is issued a dnf -y update. That's all. Hardware is an Intel PSL5000 mainboard with 2 E5450 Xeon processors. Doubt that is relevant info but thought I would include it.

Any suggestions from the crowd? This seems like a major issue that would be quickly recognized by the community but all my searching seems to suggest changing ONBOOT to yes fixes the problem. But apparently not in this case. I have even hooked up a switch to the port so it sees a link, thinking maybe it will not up the interface if there is no link present, but still no joy.

Answers


Randy Mad-Dog February 2016

I finally figured it out. Been struggling with this since yesterday. It seems that the regular network service is not enabled by default since NetworkManager is. When I disabled NetworkManager, the system was left with nothing to work the network interfaces. Issuing this command:

systemctl enable network.service

did the trick. There seems to be a lack of documentation on this gotchya from my perspective, because it makes no sense that you can ifup enp4s0f1 if there is no network service running. I suppose issuing an ifup enp4s0f1 also starts the network service. I would think it would be good to have ifup or any of those commands state "Network service is not running, starting it..." before automatically starting it for the user. This would be a good tip-off to anyone trying to sort through this.

Anyway, just wanted to update this for anyone else who might come across this post with the same problem. Once you remove networkmanager, or the modifying the ifcfg files so that it does not use it, you must also enable the network service if you want the interfaces to be available at boot time, even if you have ONBOOT=yes. With network service and networkmanager both disabled, ONBOOT will do nothing for you.

Post Status

Asked in February 2016
Viewed 1,644 times
Voted 9
Answered 1 times

Search




Leave an answer