Chris I February 2016

Hadoop namenode daemon silently stops after 5 seconds

I am relatively new to the wonders of Hadoop, but I am trying to manually build a cluster using the official Apache Hadoop documentation for Hadoop version 2.7.2. When I run the command: $HADOOP_PREFIX/sbin/hadoop-daemon.sh start namenode I am returned to my console with a message stating that the daemon is starting, and the location of the .out file. When I vim to that file path, I am met with:

ulimit -a for user hadoop
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 15017
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 4096
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

Running the start namenode command again will give me the same message that the daemon is starting and the location of the log file (same location).

Here is what I get when I look at the .log file:

2016-02-03 16:03:04,092 INFO org.apache.hadoop.hdfs.server.namenode.NameNode: STARTUP_MSG:
/************************************************************
STARTUP_MSG: Starting NameNode
STARTUP_MSG:   host = namenode_dns_name/127.0.1.1
STARTUP_MSG:   args = []
STARTUP_MSG:   version = 2.7.2

What I know so far is that:

  • Syntax errors in my configuration files will result in an error at the top of the log file
  • My namenode daemon is silently crashing roughly 5 seconds after being started
  • Improper settings in my configuration files can result in the namenode daem

Answers


Chris I February 2016

Log file indicated that the process threw a non Bind IOException due to the desired port being already taken. I now can also add to my list of known things that an '@' in vim indicates that a single line string exceeds the line size and is not the end of the file.

Post Status

Asked in February 2016
Viewed 2,869 times
Voted 14
Answered 1 times

Search




Leave an answer